MCrypt Installer for OS X Server

Compatibility

  • OS X 10.11.x El Capitan with Server app 5.x (SIP compatible)
  • OS X 10.10.x Yosemite with Server app 4.x or 5.x
  • OS X 10.9.x Mavericks with Server app 3.x
  • OS X 10.8.x Mountain Lion with Server app 2.x

Note: If MCrypt is already installed and loadable by PHP, the installer will exit without making changes.


For both, OS X 10.10 and 10.11 with OS X Server 5

The PHP module installed here:

/usr/local/lib/php/extensions/mcrypt.so

We add/edit the mcrypt module location in /etc/php.ini

extension=/usr/local/lib/php/extensions/mcrypt.so

For OS X 10.8, 10.9 and 10.10 with OS X Server 2-4

PHP modules are installed here:

/usr/lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so
/usr/lib/php/extensions/no-debug-non-zts-20100525/mcrypt.so
/usr/lib/php/extensions/no-debug-non-zts-20090626/mcrypt.so

Your system will use the correct version

We enable the mcrypt module location in /etc/php.ini

extension=mcrypt.so

What is installed and how do I remove files installed by this package.

Please see the Installer FAQ.

The topicdesk Mcrypt installer is a free download.

 

 

73 replies
Newer Comments »
  1. Jeff Johnson
    Jeff Johnson says:

    Good to hear this is working well. Thanks for taking the time to post a success.

    @Peter – we do an apachectl graceful during the postinstall script, then we test to make sure the extension loaded successfully.
    Did you need to restart apache after the install ???

    Reply
  2. Yohannes
    Yohannes says:

    This might be a trivial question. However I did run the installer(Mcrypt.pkg). But the Mcrypt extension was not installed. The /usr/local/lib/libmcrypt folder is empty and etc/php.ini file has not been created. Is there something else I need to run after running Mcrypt.pkg.

    Reply
  3. Jeff Johnson
    Jeff Johnson says:

    @Yohannes

    The installer checks to determine if you have mcrypt already installed/loaded using
    php -m | grep mcrypt
    If the test above returns mcrypt, then the installer writes this file [/tmp/mcrypt-already-installed.html] and exits without touching your installation.

    We also assume you already have an /etc/php.ini file.
    If you don’t have this file then you should either create it or copy the default (depending on your needs).
    cp /private/etc/php.ini/default /private/etc/php.ini

    If you just want the files installed – they are archived here
    /usr/local/topicdesk/mcrypt/mcrypt-10.8-and-10.9.tgz
    You can move them around manually or install them with
    sudo tar -xzf /usr/local/topicdesk/mcrypt/mcrypt-10.8-and-10.9.tgz -C /

    Hope that helps.

    Reply
  4. Ben
    Ben says:

    Hi, I have just attempted to use this installer to download mcrypt. The installer ran with no errors however the /usr/local/lib/libmcrypt directory contained no files and I was still getting the “Mcrypt PHP extension required.” message when I tried to run anything.

    I added the extension=mcrypt.so to the file “/etc/php.ini.default” which was the only php.ini file I could find in /etc. Still nothing happened. I then copied the php.ini.default file to php.ini and everything started working. Despite this, the /usr/local/lib/libmcrypt is still empty.

    Is mcrypt installed correctly and if so where are the files?

    Many thanks,
    Ben

    Reply
  5. Jeff Johnson
    Jeff Johnson says:

    Hi Ben

    Our installer makes some assumptions about your environment.. and our assumptions may not cover every scenario.

    Did you get this sorted out?
    If not, contact me through the contact page and we’ll check it out.

    Bottom line, the mcrypt installer does very little.
    It expands an archive (installs the libs)
    And IF you have an existing /etc/php.ini we add the appropriate lines.

    There are reasons the installer could abort (without notice), for example if you are missing an /etc/phpini.

    Feel free to use the Contact link above to get in touch with me.
    We should be able to sort it out within a few minutes.

    Jeff

    Reply
  6. Mark
    Mark says:

    Thank you! Just had to change the extension_dir line in php.ini to:

    extension_dir = “/usr/lib/php/extensions/no-debug-non-zts-20100525”

    Restart apache and Bingo! It worked!

    Reply
  7. Ian
    Ian says:

    I got this error message when I run composer.

    “Mcrypt PHP extension required.
    Script php artisan clear-compiled handling the post-install-cmd event returned with an error”

    Any suggestions on how to fix this?

    Reply
  8. Luciano
    Luciano says:

    I try a lot of things but this is only one thats REALY WORK! Very nice, thank you so much! I try Brew, and a lot off others solutions but nothing works.

    Reply
  9. Brian
    Brian says:

    Thank you!
    I was hesitant to use this installer, but decided to anyway and it seems to have worked out!
    Easy solution that would have saved me hours today.

    Reply
Newer Comments »

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published.