Roundcube for macOS Server

What’s new in version 1.3.6?
Compatibility
  • Mac OS X Server 10.8.3 w/ Server 2.x – through -> 10.13.x High Sierra w/ Server.app 5.6.x
Why we made this installer

Mac OS X Server administrators usually wear many hats (entrepreneur, designer, etc.). We choose the Mac expecting it to have a nice GUI interface and all our basic needs to be met out of the box.
Apple used to provide webmail services in earlier versions of OS X Server (10.7 and earlier). For reasons unknown, webmail was dropped in 10.8 leaving it up to administrators to roll their own solution.

An OS X Server administrator with a Unix background could jump through all the hoops in a couple of hours – but lets face it, most OS X Server administrators would be stuck facing a day or more of tutorials, articles and frustration to get webmail working on their server.

As consultants specializing in mail services for OS X Server, we found ourselves repeating the same steps over and over with each new server installation. So we decided to apply our rule of thumb: if a repeatable process takes more than 30 minutes – document, automate and share.

What does the installer do?

Our installer for Roundcube for OS X Server installs Roundcube Webmail as a simple WebApp available to any website configured inside Server.app. When the WebApp is enabled (by default, its enabled for all sites), you can access webmail by adding /mail /webmail or /roundcube to your website URL.

Please browse our FAQs for answers to most questions.

See current changelog for a complete list of fixes and additions.
Please read our FAQs as well.

The topicdesk Roundcube installer is a free download.

 

 

205 replies
« Older Comments
  1. Sean
    Sean says:

    I’ve just tried updating from roundcube 1.2.5 to 1.3 and it seems to break the ‘chbox’ plugin, I see this in the error log:

    PHP Fatal error: Call to undefined function rcube_label() in /usr/local/topicdesk/roundcube/1.3/plugins/chbox/chbox.php on line 64

    It seems that it was fixed by the plugin authors here:
    https://github.com/6ec123321/chbox/commit/ceebad9c6a105e52dc72e9db5be52328ef056445

    So I guess one must be careful to not only keep roundcube itself up-to-date, but all the plugins too…

    Reply
  2. drclic
    drclic says:

    Hi. Just tried to install it on the 5.4 server. Can’t get it to work, when I try to connect to the page, I get a blank page.
    Are you planning on releasing an update?

    Reply
      • drclic
        drclic says:

        Hi. I updated from server 5.3. Tried the timezone issue, didn’t change anything. Besides, it happens even before I can get to the login screen. It’s just blank.

        Reply
          • drclic
            drclic says:

            There is an error indeed in the Apache2 error.log:

            PHP Startup: mcrypt: Unable to initialize module\nModule compiled with module API=20121212\nPHP compiled with module API=20160303\nThese options need to match\n in Unknown on line 0

          • drclic
            drclic says:

            I tried the mcrypt installer, at the end of the installation process, I get :
            Uh-Oh: MCrypt failed to load

            Found this PHP module error you may want to investigate

            # Run a syntax check with: /usr/bin/php -l

            PHP Warning: PHP Startup: mcrypt: Unable to initialize module
            Module compiled with module API=20121212
            PHP compiled with module API=20160303
            These options need to match

            in Unknown on line 0

          • Sean
            Sean says:

            Have you been keeping your roundcube up-to-date? If you are on roundcube 1.2 or later, it doesn’t even use mcrypt anymore, so you can delete all the mcrypt stuff that the topic desk installer installs. There’s another thread about that here somewhere…

          • Sean
            Sean says:

            You should not install mcrypt! It has been unmaintained for a decade, is deprecated, and is entirely removed in PHP 7.2. Like I said, roundcube doesn’t even need it anymore.

          • drclic
            drclic says:

            Updated to the latest RoundCube (I was with 1.1), removed everything linked to mcrypt, rebooted the computer.
            No more error message, but still not working.
            I guess there is something with High Sierra or the new version of the server.

          • Sean
            Sean says:

            Sound like you’ve solved one problem and now hit another. Did you also check roundcube’s logs (not just apache’s).

          • drclic
            drclic says:

            Hi again.

            Every time I try to connect, this is what appears in the logs.

            [03-Oct-2017 20:38:16 Europe/Paris] PHP Fatal error: Cannot use ‘Float’ as class name as it is reserved in /usr/local/topicdesk/roundcube/1.1.4/plugins/carddav/inc/sabre-vobject/lib/Sabre/VObject/Property/Float.php on line 18

          • Sean
            Sean says:

            hmm, I’ve never seen that, but I don’t use that plugin. If you disable the CardDAV plugin, do things work? Those plugins that the topicdesk installer provides are also old by now. Updating roundcube itself doesn’t update the plugins. I had to update/disable some plugins after major roundcube versions because things would break otherwise.

      • Richard Williams
        Richard Williams says:

        I have just done this. I downloaded the complete package for roundcubemail-1.3.1-complete.tar.gz from the roundcube web site. Then in /usr/local/topicdesk/roundcube I renamed WebApp to WebApp.bak. Next step was to tar-zxvf roundcubemail-1.3.1-complete.tar.gz. Then copy the folder roundcubemail-1.3.1 to /usr/local/topicdesk/roundcube/1.3.1. Nearly there. Final steps are:
        1. copy 1.1.4/config/config.inc.php to 1.3.1/config/config.inc.php (preserve your settings)
        2 copy 1.1.4/plugins/managesieve/config.inc.php to 1.3.1/plugins/managesieve/config.inc.php
        3 copy all the 1..1./plugins/carddav folder to 1.3.1/plugins as this doesn’t exist in the new version.

        Reply
    • drclic
      drclic says:

      I finally have been able to log.
      Once the carddav plugin disabled, I was able to se the login page, but after, blank page.
      I restarted the computer, had another error in log, concerning chbox plugin. Once this one is disabled as well, I can finally login.
      Still, not being able to use the carddav is a bummer. At least I can access mails and more than that, configure server side rules.

      Reply
        • drclic
          drclic says:

          I checked on the plugins list on RoundCube.net, downloaded the latest version and installed it, got the blank page again.
          Thing is it is directly related to version 5.4 of MacOSServer, I have another server under 5.3, everything works very well with the installer, just out of the box.

          Reply
          • Sean
            Sean says:

            Yeah, could be something to do with 5.4. Are you running that on 10.12 or 10.13? That could be a difference too: 10.13 now has PHP 7.

            Note: running the topic desk installer “just out of the box” is a horrible idea, because it’s so old and there have been various security bugs fixed in roundcube since.

          • drclic
            drclic says:

            I’m on macOS 10.13, Server 5,4 cannot be installed on 10.12.
            I did not update very often because the webmail is not directly accessible from outside, only local network and VPN.

    • Ahmed Elsaid
      Ahmed Elsaid says:

      This is what I did to get it working, I used the uninstaller to uninstall everything. after repot re-install only the the Roundcube webapp without MCrypt and make sure you don’t install the CardDav plugin. after installing, download the most recent roundcube version and replace everything at /usr/local/topicdesk/1.1.4 with the newer downloaded version with exception to the config folder you should keep the original one from the installation. Hopefully that works for you

      Reply
  3. Ben Greenfield
    Ben Greenfield says:

    I was able to get Roundcube installed and running using Server.app 5.4.

    I installed the latest Roundcube version 1.3.3
    Replaced the symlink to the old version
    /usr/local/topicdesk/roundcube/

    WebApp -> /usr/local/topicdesk/roundcube/1.1.4
    WebApp -> /usr/local/topicdesk/roundcube/roundcubemail-1.3.3/

    I tried to follow the above instructions from Richard Williams.

    At that point I was getting the blank screen and I at the log files and found this error in the apache2/errror.log
    [Thu Nov 09 13:03:26.766935 2017] [php7:error] [pid 41481] [client 127.0.0.1:59558] PHP Fatal error: Uncaught Error: Class ‘PEAR’ not found in /usr/local/topicdesk/roundcube/roundcubemail-1.3.3/program/lib/Roundcube/bootstrap.php:101\nStack trace:\n#0 /usr/local/topicdesk/roundcube/roundcubemail-1.3.3/program/include/iniset.php(63): require_once()\n#1 /usr/local/topicdesk/roundcube/roundcubemail-1.3.3/index.php(40): require_once(‘/usr/local/topi…’)\n#2 {main}\n thrown in /usr/local/topicdesk/roundcube/roundcubemail-1.3.3/program/lib/Roundcube/bootstrap.php on line 101

    I discovered that pear is in the vendor folder in /usr/local/topicdesk/roundcube/1.1.4/.

    I copied it to my roundcubemail-1.3.3. We fixed the blank screen but I still couldn’t login in.

    Then in the apache2/access.log I saw that I was missing a couple of items program/js/

    I copied them over from the 1.1.4/program/js folder.
    jquery.min.js
    jstz.min.js

    Reply
  4. johann beda
    johann beda says:

    After using the topicdesk Roundcube installer way back when, I was hoping to use it with a newly configured High Sierra server running Server.app 5.6

    After running the installer, I get taken to the roundcube webpage at http://127.0.0.1/roundcube/ but when I try to log into an account I get an error of “invalid request no data was saved”.

    Is there something I need to do to configure Roundcube after the installation?

    Going to http://127.0.0.1/roundcube/installer/ give me a note saying “The installer is disabled!” and suggesting I set $config[‘enable_installer’] = true; in RCUBE_CONFIG_DIR/config.inc.php to enable the installer again.

    Thanks in advance for any insight.

    Reply
    • johann beda
      johann beda says:

      OK, maybe I fixed it. Like Richard Williams and Ben Greenfield suggested, I downloaded the latest roundcubemail-1.3.6 and put it next to /usr/local/topicdesk/roundcube/1.1.4 and created a symbolic link so that WebApp -> /usr/local/topicdesk/roundcube/roundcubemail-1.3.6/

      I copied the following files/folders to the appropriate place in 1.3.6:
      1.1.4/config/config.inc.php
      1.1.4/plugins/managesieve/config.inc.php
      1.1.4/plugins/carddav
      1.1.4/program/js/jquery.min.js
      1.1.4/program/js/jstz.min.js

      And now I am able to log in. Still need to do some testing of course.

      I have not copied the managesieve config file – I don’t know if I need to. I have not disabled the carddav plugin as some have mentioned is necessary.

      1.1.4/plugins/managesieve/config.inc.php

      Reply
  5. Jeffrey
    Jeffrey says:

    Wonderful! Excellent update, works like a charm.
    For best results, uninstall roundcube first, then run the installer again to really install 1.3.6 otherwise the old roundcube remains intact.
    Thanks for a great piece of software!

    Reply
    • Jeff Johnson
      Jeff Johnson says:

      Thanks for the comments Jeffrey.

      Not everyone will want to uninstall/reinstall.

      Uninstalling removes all admin and user configuration, this includes user preferences including their signature, name, etc.

      Use the upgrade option to retain settings (for better or worse).

      Note: filters (vacation message, forwarding, etc) are stored outside of roundcube, so whether you uninstall/re-install or you upgrade, user rules remain untouched.

      Reply
  6. Fonny
    Fonny says:

    Hi,

    Great works of you again. Thank you very much.
    Sincerely hope Topicdesk will still be here to assist when Apple stops their updates.

    I also needed to uninstall/reinstall to get roundcube running. But works flawless after.

    Reply
  7. Erik
    Erik says:

    Hi,
    I am not using the build in address book, but an external carddav server (Daylite). So the RCMCardDAV plugin is not installed.
    So I manualy installed the plugin, also Httpful, and was able to enter the carddav cridentials. But now the plugin throws errors like [12-Jun-2018 08:40:55 Europe/Amsterdam] PHP Fatal error: Uncaught Exception: String could not be parsed as XML in /usr/local/topicdesk/roundcube/roundcubemail-1.3.6/plugins/carddav/carddav_common.p$
    Stack trace:
    #0 /usr/local/topicdesk/roundcube/roundcubemail-1.3.6/plugins/carddav/carddav_common.php(117): SimpleXMLElement->__construct(”)
    Probably an error sting is parsed.
    Can anyone help getting a full encrypted carddav account working?

    Reply
    • Jeff Johnson
      Jeff Johnson says:

      @Erik

      Be sure you are using the latest version of rcmcarddav (currently 3.0.2)
      https://github.com/blind-coder/rcmcarddav

      You bring up a good point.
      As it is now, the installer disables the carddav option if carddav isn’t running (and passes a few tests).
      We’ll update the package so installation of the plugin is always allowed, but the plugin won’t be enabled in roundcube config unless tests pass.

      For now, you could temporarily enable carddav on your server, then re-run the roundcube installer.

      Reply
  8. Efraimoglou Dimitris
    Efraimoglou Dimitris says:

    After upgrading my MacOSX Server to OS X 10.13, I upgraded Roundcube to 1.3.6.
    It worked fine, like before the 2 upgrades.

    But due to a vast amount of websites we are serving, I am forced to
    use PHP5.6 instead of PHP7 that 10.13 comes with.

    And 1.3.6 does not seem to like PHP5.6 because when I login it shows nothing
    (a white page, instead of the standard view that I see when i have PHP7 active).

    Before the OSX upgrade, the (old) Roundcube had no problem with PHP5.6.
    But 1.3.6 seem to have…

    Any ideas on what to do?

    Reply
  9. Sean
    Sean says:

    1.3.6 does work with PHP 5.6. That’s not the cause of your white screen. It was discussed here before… I think it was related to the PHP time zone not being set…

    Reply
  10. Adam Cheetham
    Adam Cheetham says:

    Hi, does anyone know if you can change the website instead of being /mail to mail.example.com or something. This is what I gathered from reading the description above. (I haven’t actually installed yet was just asking beforehand)

    Reply
    • johann
      johann says:

      Yes, you can create a website in Server.app called mail.example.com and point the root of that website to the appropriate location. In my setup I have the http site redirect to the https site which points to something like: /usr/local/topicdesk/roundcube/roundcubemail-1.3.6

      Reply
« Older Comments

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply to Rob Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.