Roundcube for macOS Server

What’s new in version 1.3.6?
Compatibility
  • Mac OS X Server 10.8.3 w/ Server 2.x – through -> 10.13.x High Sierra w/ Server.app 5.6.x
Why we made this installer

Mac OS X Server administrators usually wear many hats (entrepreneur, designer, etc.). We choose the Mac expecting it to have a nice GUI interface and all our basic needs to be met out of the box.
Apple used to provide webmail services in earlier versions of OS X Server (10.7 and earlier). For reasons unknown, webmail was dropped in 10.8 leaving it up to administrators to roll their own solution.

An OS X Server administrator with a Unix background could jump through all the hoops in a couple of hours – but lets face it, most OS X Server administrators would be stuck facing a day or more of tutorials, articles and frustration to get webmail working on their server.

As consultants specializing in mail services for OS X Server, we found ourselves repeating the same steps over and over with each new server installation. So we decided to apply our rule of thumb: if a repeatable process takes more than 30 minutes – document, automate and share.

What does the installer do?

Our installer for Roundcube for OS X Server installs Roundcube Webmail as a simple WebApp available to any website configured inside Server.app. When the WebApp is enabled (by default, its enabled for all sites), you can access webmail by adding /mail /webmail or /roundcube to your website URL.

Please browse our FAQs for answers to most questions.

See current changelog for a complete list of fixes and additions.
Please read our FAQs as well.

The topicdesk Roundcube installer is a free download.

 

 

206 replies
« Older CommentsNewer Comments »
  1. Scott
    Scott says:

    Hi,
    I have 0.9.5 on ML 10.8.5 server and it has worked great. Just recently some users could not log in, not getting an error, but the screen turns white fails to connect.

    So I thought a new install would be the answer. But someone above said to install only over a working version. Anybody know what I can try to fix mine?

    Thanks!

    Reply
  2. Jeff Johnson
    Jeff Johnson says:

    Scott

    Try disabling the carddav plugin.. Look in the Roundcube Installer FAQs for some info
    or go directly to
    /usr/local/topicdesk/roundcube/WebApp/config/main.inc.php
    ## remove carddav from the plugin line.

    Your version is dependent on Postgres and its a bit fragile.
    If you don’t mind losing user preferences (full name, signature, edit/compose preferences, etc) then I would delete and re-install (the new version uses sqllite instead of postgres)
    Existing filters and vacation messages will be retained (they are not stored in the user database) but other user preferences will be reset.
    If thats OK with you, then do this:
    sudo rm -rf /usr/local/topicdesk/roundcube
    Then run the new installer.

    If you’d like to run the latest version of roundcbe, after running our installer use the directions in our FAQ section to upgrade.

    Jeff

    Reply
  3. Scott
    Scott says:

    Jeff,
    Sounds good. I don’t really have much in the way of user prefs beside the defaults, but I do have lots of filters and I had saved those out from one of the accounts I could get in to.

    So if I remove what I have and install the newer one, should I still remove that carddav line?

    Also, I’m not clear what you mean in your last line about the latest version of roundcube after the installer. Isn’t the installer 1.03a the latest?

    Thanks!

    Reply
  4. Jeff Johnson
    Jeff Johnson says:

    @Scott

    If you don’t have a working carddav service on your server, then you should remove carddav from the plugin line.
    When the carddav plugin is enabled, it checks the user’s carddav account during login.
    Config issues can cause login delay or faulure.

    We don’t update the installer with every roundcube release because its easy to update roundcube on your own.
    1.0.3 was the current version of roundcube when we built this installer, the latest version is 1.1.2.
    Instructions are in our FAQ section.
    Install instructions

    Reply
  5. Scott
    Scott says:

    Hey Jeff,
    So I removed the carddav as you said and it worked.

    But do you recommend installing the 1.0.3 and then upgrading to 1.1.2?

    Thanks,
    Scott

    Reply
  6. David M
    David M says:

    I’ve installed and set up Roundcube on 2 OS X servers now. Everything works great with one exception.
    Not really a fault of the installer but still an issue I hope someone can help me with.
    I’d like to get shared folders set up on the mail server and don’t know how to do it with 10.10.
    When I had 10.5 (I think) I used SirAdmin to create and share folders for cyradmin.

    Can anyone tell me how to set them up and expose them in Roundcube?

    Thanks,
    David

    Reply
  7. David M
    David M says:

    Sorry to post another question right away, but I just tried to upgrade via your instructions and got these errors:

    PHP Warning: require_once(/usr/local/topicdesk/roundcube/1.0.3a/installer/rcube_install.php): failed to open stream: No such file or directory in /usr/local/topicdesk/roundcube/1.0.3a/bin/update.sh on line 25
    PHP Fatal error: require_once(): Failed opening required ‘/usr/local/topicdesk/roundcube/1.0.3a/installer/rcube_install.php’ (include_path=’/usr/local/topicdesk/roundcube/1.0.3a/program/lib:.:’) in /usr/local/topicdesk/roundcube/1.0.3a/bin/update.sh on line 25

    Reply
  8. Jeff Johnson
    Jeff Johnson says:

    David – Post exactly what steps you took.
    Make sure you run install.sh from the NEW version which should remain in your Downloads folder.
    Don’t manually copy any files.
    Your existing version needs to be running for an upgrade to work.

    Reply
  9. Jeff Johnson
    Jeff Johnson says:

    @David

    I don’t have vetted (postable) instructions.
    Generic instructions for dovecot 2.x will work, the files are just in different location:
    /Library/Server/Mail/Config/dovecot/dovecot.d/

    If you want rough notes, email me
    jeff at topic desk. com

    Reply
  10. Kevin Allen
    Kevin Allen says:

    DEFINITELY backup and test before upgrading to Server App 5.0.3 if you are using the topicdesk install of roundcube. There seems ot be a major change in how server deals with it’s default apps (directing them through port 34543 instead of 443 and 34580 instead of 80 so your default site redirection to roundcube keep adding a :34543 after the domain name before the /webmail in the url. Not sure of a clean fix so far. I’ve got a manageable solution in place by configuring a new website in the server app and setting it to port 443 with some changes to the apache .conf files for the sites themselves. Apple again with a MAJOR change that is undocumented to users before the upgrade is widely available. Test test test test and have a solid backup.

    Reply
  11. Athanasios Alexandrides
    Athanasios Alexandrides says:

    We are in the process of testing it with Server 5 on Yosemite and El Capitan. There is no ETA yet, but I’d think in about 2-3 weeks. When ready, we will post it on our site, tweet about it and send out a newsletter.

    Reply
  12. Roland Sambain
    Roland Sambain says:

    I am experiencing some issues on OSX 10.11.1 and Server 5.0.15. Have to add a ‘/’ to the end of the URL to get it to work which has been reported before and also ‘vacation’ filters that have been disabled continue to function until the filter is actually deleted.

    Reply
  13. Will O.
    Will O. says:

    I just ran the install on my Mac Mini Server El Capitan and it works!!! A big thanks to your team for this amazing solution to a much needed webapp.

    Reply
  14. Thomas
    Thomas says:

    Hi there, after updaten to Server 5.0.3 I can’t connect to round cube any more. What to do?
    Need the “out of office” System. Thanks.

    Reply
      • Jeff Johnson
        Jeff Johnson says:

        Thomas
        Please post the results of these two commands

        grep -E '_https.]'  /usr/local/topicdesk/roundcube/WebApp/config/*
        head /usr/local/topicdesk/roundcube/WebApp/.htaccess
        Reply
        • Thomas
          Thomas says:

          Hi Jeff, here are the results:

          command 1:

          /usr/local/topicdesk/roundcube/WebApp/config/defaults.inc.php:$config['force_https'] = false;
          /usr/local/topicdesk/roundcube/WebApp/config/defaults.inc.php:$config['use_https'] = false;

          command 2:

          DirectoryIndex index.php
          
          # AddDefaultCharset	UTF-8
          AddType text/x-component .htc
          
          
          php_flag	display_errors	Off
          php_flag	log_errors	On
          # php_value	error_log	logs/errors
          Reply
          • Jeff Johnson
            Jeff Johnson says:

            @Thomas

            Please send results of:
            grep topic /var/log/apache2/error_log | tail

            I could take a look directly at your server – it might yield some info to help others. Use the Contact tab above if you are able to arrange remove access.

            Jeff

    • Athanasios Alexandrides
      Athanasios Alexandrides says:

      We are in the process of testing it with Server 5 on Yosemite and El Capitan. Should be ready this month.

      Reply
  15. Q
    Q says:

    just installed the current installer on a server with OS X 10.11.2 and server.app version 5.0.15.
    it worked perfectly right out of the box.
    thanks a lot.

    Reply
    • Jeff Johnson
      Jeff Johnson says:

      @Nick

      The following files/directories are includes in the installer:

      Roundcube:

      /usr/local/topicdesk/roundcube/
      /Library/Server/Web/Config/apache2/webapps/com.topidesk.roundcube.webapp.plist

      mcrypt:

      /usr/local/topicdesk/mcrypt/
      usr//lib/php/extensions/no-debug-non-zts-20090626/mcrypt.so
      usr//lib/php/extensions/no-debug-non-zts-20100525/mcrypt.so
      usr//lib/php/extensions/no-debug-non-zts-20100525/xdebug.so
      usr//lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so
      usr//lib/php/extensions/no-debug-non-zts-20121212/opcache.a
      usr//lib/php/extensions/no-debug-non-zts-20121212/opcache.so
      usr//lib/php/extensions/no-debug-non-zts-20121212/xdebug.so
      usr//local/bin/libmcrypt-config
      usr//local/include/mcrypt.h
      usr//local/include/mutils/mcrypt.h
      usr//local/lib/libmcrypt.4.4.8.dylib
      usr//local/lib/libmcrypt.la
      usr//local/man/man3/mcrypt.3
      usr//local/share/aclocal/libmcrypt.m4
      Reply
  16. MrEdd
    MrEdd says:

    would be great, to have the “pop3fetcher” plugin also pre-installed
    (newbie, so not sure if ‘pre-installation is possible)

    Reply
  17. Dave S
    Dave S says:

    I was running Roundcube 103 on my mavericks server fine but after recently upgrading to el capitan I found I had to reinstall roundcube, after which my server address books are gone, only personal address books exist. I also can’t seem to add an server address book. Is this a problem with your install on El Capitan or just my system? Any help would be appreciated

    Reply
« Older CommentsNewer Comments »

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.