Roundcube Webmail Installer for OS X 10.8/10.9/10.10 with Server 2.x/3.x/4.x

Now compatible with
  • OS X Server 10.8.3+ (Mountain Lion, Server app 2.x)
  • OS X Server 10.9.x (Mavericks Server.app 3.x)
  • OS X Server 10.10.+ (Yosemite Server.app 4.x)
This release includes
  • Roundcube version 1.0.3 installed as a WebApp
  • CardDav Integration
  • ManageSieve Plugin (mail filters, vacation reply)
  • Updated database backend, no longer dependent Postgres
  • Mcrypt included
If you are upgrading from a previous version

This installation replaces your previous version. Any custom roundcube configuration, user preferences or updates to graphics (logo) are not retained. Your previous installation is backed up in this directory.

/usr/local/topicdesk/roundcube 
A note about Carddav

If carddav is enabled on your server, the installer will read your carddav settings and apply those settings to the Roundcube carddav plugin.

If you don’t use carddav on your server, you can disable the roundcube plugin with:

   sudo perl -p -i -e "s/'managesieve', 'carddav'/'managesieve'/g" /usr/local/topicdesk/roundcube/WebApp/config/config.inc.php 

See current changelog for a complete list of fixes and additions.
Please read our FAQs as well.

The topicdesk Roundcube installer is a free download.

 

 

108 replies
  1. Willow
    Willow says:

    Help, thanks a lot for this.
    Now my roundcube respond 😀 and the webmail works. However i have a mistake whith manage sieve: when i want to connect on filter i have a message that he couldn’t connect to server. I test the command cardav but no way.
    Any idea?

    Reply
  2. Willow
    Willow says:

    It’s again me…
    I solve my problem: the 0,95 files of round cube was already in the path of round cube, i put the file on the trash and round cube was broken. So i take the config’s file of managesieve and put them in round cube 1.03 file and it’s works.
    thanks again

    Reply
  3. Guest
    Guest says:

    Can’t get filters working on Mavericks server. The error is “Unable to connect to manage sieve server”.

    Port 4190 is open and listening.

    /Library/Logs/Mail/mail-err.log has these entries:

    Nov 27 22:46:52 managesieve-login: Warning: Auth connection closed with 1 pending requests (max 0 secs, pid=57430, EOF)
    Nov 27 22:46:52 auth: Fatal: master: service(auth): child 56954 killed with signal 11 (core dumps disabled)
    Nov 27 22:54:57 managesieve-login: Warning: Auth connection closed with 1 pending requests (max 0 secs, pid=57706, EOF)
    Nov 27 22:54:57 auth: Fatal: master: service(auth): child 57435 killed with signal 11 (core dumps disabled)
    Nov 27 22:59:04 managesieve-login: Warning: Auth connection closed with 1 pending requests (max 0 secs, pid=57918, EOF)
    Nov 27 22:59:04 auth: Fatal: master: service(auth): child 57712 killed with signal 11 (core dumps disabled)

    Reply
  4. Oliver
    Oliver says:

    Great installer for those who want webmail back on Os X Server 10.10.x, it works flawlessly.
    I have some little issues I’d like to work out so I could go on production. – from 10.6.8 to 10.10.x
    I can’t get autoreply/vacation to work ([url]”/faqs/roundcube-faq/192-why-do-vacation-messages-not-work-with-roundcube-webmail”[/url]) nor find some config settings ([url]”/faqs/roundcube-faq/195-topicdesk-roundcube-logs”[/url]) as I see nowhere the main “main.inc.php”. Does main.inc.php is now config.inc.php.

    Any insight would be appreciated, but I’ll continue digging by myself.
    thx.

    Reply
  5. Jeff Johnson
    Jeff Johnson says:

    For the filter (vacation message) to work, make sure the filter set and the filter are both enabled.
    When you create the filter/vacation-message, in the ‘Additional EMail Addresses’ box, you must put your email even if its not an ‘additional’ address… If that box doesn’t contain your address, it won’t work.

    We’ll add this to a FAQ.

    Reply
  6. Oliver
    Oliver says:

    OK I figure WHERE to add the additional email when creating the filter.
    Right in front of me :)
    And for the the log being created it is indeed in the defaults.inc.php

    Reply
  7. Jeff Johnson
    Jeff Johnson says:

    Regarding config files.

    In version of roundcube before 1.0, you had:
    main.inc.php
    db.inc.php

    In 1.0+ things changed, the above were replaced with:
    defaults.inc.php
    contains the roundcube defaults for all settings previously in main.inc.php and db.in.php
    config.inc.php
    these are ‘your’ settings.. this is where you override any settings that are in defaults.inc.php

    The idea is that defaults.inc.php can change when you update roundcube.
    Any of your settings will remain though, because config.inc.php overrides them.

    Put any of your settings in config.inc.php

    main.inc.php and db.inc.php can be discarded.

    The roundcube documentation and release notes may help.
    http://roundcube.net/news/2014/04/07/roundcube-webmail-1.0.0-released/

    Reply
  8. Jeff Johnson
    Jeff Johnson says:

    @Oliver

    Don’t change defaults.inc.php
    Any settings from defaults.inc.php that you would like to be different should go into config.inc.php

    Simply copy the line from defaults and paste to config.inc.php with your change.

    Reply
  9. Olivier
    Olivier says:

    @Jeff

    yes I finaly did not touch the defaults.inc.php at all,
    as I realized this was not the correct way.
    So far everything is OK thanks to your script.

    Thank you for this !

    I’ve just try to get defaults.inc.php vacation_sieve ([url]”https://github.com/arodier/Roundcube-Plugins”[/url]) plugin working with no success at all. it is the simpliest and nicer one I’ve found. as it does not rely on postfixadmin or vacation binary as other plugins.

    Just can’t figure out to have the Os X GeneratedUID instead of the for the rules path, so I always have an error reading and saving.
    Weird too is that it seems to be the _www user and not _dovecot user acting ? and your setup works ok using the _dovecot user.

    I know there is a vacation sieve with your setup and it is working
    BUT
    it only send ONE email !? during the date range, and I want (would like) a responder for each email received.
    I’m not good enough – well I just don’t know at all – php, so even if I’ve tried many solution I did not suceed is saving the script.
    I did read the manage sieve.php as it is working ot try to figure out how to do but that’s too much for me.

    Is there a way to alter some config, somewhere, so an email is sent each time and not only once ?!
    I don’t get the purpose, and did not figure where was that parameter.

    I’d like to move 200 emails to deal from a 10.6 Server,
    we need webmail for sure, as I don’t see myself adding a script by hand each time someone goes in holidays.

    I’ll dig a bit more as I WANT this :)

    thx for all the help.

    cheers.

    Reply
  10. Jeff Johnson
    Jeff Johnson says:

    @Oliver

    I’m not going to be much of a help with plugins.

    Our goal is to simplify the installation of roundcube (and its dependencies) and as part of this – we include a couple preconfigured plugins for convenience. I can’t claim any expertise with these plugins or others.

    You’ve probably already explored this site – but just in case:
    http://www.roundcubeforum.net

    Reply
  11. Olivier
    Olivier says:

    @Jeff,

    Don’t worry, you did a very great job.
    I managed ot get the correct GUID with php exec, but still have the “Invalid script name … stuff.
    I’ll work on this when I have time and I now am going to get some rest.

    my best.

    Reply
  12. Mike O'Connor
    Mike O'Connor says:

    Just curious if the script “touches” the php.ini file. The script worked flawlessly but just after I ran it I noticed that all 20 of my WordPress sites had lost the ability to be updated. The cause of the problem was the “max_post_size” parameter in PHP.INI had changed from 8M to 351 — which meant that various commands were failing. All good here, I changed PHP.INI back, but I wasn’t sure where the problem came from. Since it started right after I ran the script, I thought I’d post this here.

    Reply
  13. Jeff Johnson
    Jeff Johnson says:

    @Mike
    We do modify /etc/php.ini
    This is a reqirement because we check for mcrypt and install if its missing, along with that – we update some settings to better accomodate the typical roundcube installation.

    I’ll contact you directly – I’d like to know more, and if we have a logic issue with the install script – we’ll fix that quickly.

    Jeff

    Reply
  14. Jeff Johnson
    Jeff Johnson says:

    @Ricardo

    This is a ‘clean installation’ and does not retain user data.
    The database backend moves from postgres to sqlite, no data is retained from postgres.
    sqlite starts with a clean database.

    There are two types of addressbooks users can store addresses
    a) Built-in roundcube addressbook.
    This stores the data in the roundcube database.. your data is in postgres and not retained with the new sqlite version.

    b) CardDav Address Book
    If you have carddav enabled and working, users could store data in your carddav server.
    These addresses would be available on the new version because the data is not stored in the roundcube DB, its stored independent of roundcube.

    If your users stored contacts in the roundcube DB, then you will need to roll-back to your previous version.
    If your roundcube install was not working before upgrading – then you probably have a damaged installation.
    I have no recovery option to recommend – although I’m sure its possible.

    If your postgres DB was working before the upgrade, then your postgres database should be fine and its simple to roll-back.
    You just need to link the WebApp symlink to your previous version.
    Here’s an example:
    # go to roundcube directory
    cd /usr/local/topicdesk/roundcube

    # list the backups
    ls

    # Update WebApp symlink to whichever version you want to load
    # This is an example with the previous version named: “0.9.5a_2014-12-07_15h57m”
    sudo ln -sfh 0.9.5a_2014-12-07_15h57m WebApp

    Thats it.. Roundcube will switch to your previous version.

    If you do this, and it works – don’t upgrade to the non-postgres version, there is no reason for you to do this.
    If you want to upgrade the version of roundube, it can be done without re-installing.

    Jeff

    Reply
  15. Ricardo Ferriera
    Ricardo Ferriera says:

    @Jeff

    The database was working fine until last night i installed an update por OS X 9 and Server App and the database stop working.

    in order to have the service working again i installed the update of roundcube.

    All the contacts were on the Built-in round cube addressbook how can i recover the information and put it on the CardDav Address Book on my mac server.

    Can you contact me and help me solve this?

    Thanks

    Reply
  16. Jeff Johnson
    Jeff Johnson says:

    @Ricardo

    The problem is the OS X Server updates break the postgres database.
    This is Apple’s installation of postgres. We configure roundcube to use Apple’s postgres.
    Once the apple update breaks the database, I haven’t had any luck repairing it. It can be repaired, but that not my area of expertise, so can’t advise.

    Hopefully you made a clone of your system before the server.app upgrade. If you did, consider rolling back to it.

    I can’t be of much help recovering/fixing your postgres DB…

    Jeff

    Reply
  17. Ricardo Ferreira
    Ricardo Ferreira says:

    @Jeff

    I did a clone of my system before the server.app update but still can’t access the database.
    I have OS X 10.9.4 and when i try to open the server.app it tells me i need OS X 10.9.5, i guess OS X downloaded the server.app update but still don’t understand why the database is corrupt if the server.app can’t be run. everything was running smoothly yesterday

    Any orientation will be helpful.

    Reply
  18. Jeff Johnson
    Jeff Johnson says:

    Ricardo
    You need to go back to exactly the way things were before.
    In your case, sounds like you should have 10.9.4 and Server 3.1.2
    A clone made before the udpates were downloaded and applied would have a working copy.
    I assume your postgres data is stored on your startup drive? if its not on the internal, then it would have been upgraded with your server app upgrade (the upgrade fails) then it wouldn’t work even if you roll-back. You would need to roll-back your data in this case also.
    Sound like you simply have a non-matching OS/Server.app.

    I can assist on a consulting basis – my mail is jeff at the domain topicdesk.com

    Reply
  19. bertrand
    bertrand says:

    Hi

    everything works fine with this installer!
    Thanks a lot, because 10.9.5 + Server upgrade brokes the webmail.

    Where can i find documentation about setting up vacation reply?
    I’ve found how it can be set up

    Thanks
    Bertrand.

    Reply
  20. Luis Rojas
    Luis Rojas says:

    Hi All,

    I was wondering if this needs to be installed in the same server as the mail server so that sieve rules work correctly. Our mail server is still running on a 10.6 server, but we are moving away from it slowly, web was one of the first to go, thus we want to install round cube, Can someone tell me if the manageSieve plugin will be able to handle the rules on our mail server? ( 10.6 )

    Reply
  21. Jeff Johnson
    Jeff Johnson says:

    Luis
    Yes, roundcube will run on a machine other than your server including the ability to add/edit filters.

    Port 4190 must be open from roundcube server to mail server.

    You’ll need to adjust imap/smtp settings here:
    /usr/local/topicdesk/roundcube/WebApp/config/config.inc.php
    Adjust the managesieve plugin config
    /usr/local/topicdesk/roundcube/WebApp/plugins/managesieve/config.inc.php

    If you are using carddav, edit the roundcube carddav plugin config
    /usr/local/topicdesk/roundcube/WebApp/plugins/carddav/config.inc.php
    If you are NOT using carddav, disable the roundcube carddav plugin with
    sudo perl -p -i -e “s/’managesieve’, ‘carddav’/’managesieve’/g” /usr/local/topicdesk/roundcube/WebApp/config/config.inc.php

    Jeff

    Reply
  22. Emil Haslund Larsen
    Emil Haslund Larsen says:

    Hi.

    Everything works great except for the vacation/filter. I have set it up (with alternate e-mail), but do not receive a reply most of the times I’m testing. Why is this? I can see the test mails pop in, but the answer is in most cases not being sent.

    Thanks in advance.
    Emil

    Reply
  23. Emil Haslund Larsen
    Emil Haslund Larsen says:

    Hi again.

    If I send from different e-mail addresses, I get 1 reply per address, but if I send another I do not get a response. Is this how it should work?

    -Emil

    Reply
  24. Philippe ASTIER
    Philippe ASTIER says:

    Hi there !

    First of all, thanks for bringing back roundcube to Server 4.0 !
    I have an issue when trying to send an email, I get a SMTP 454 error (relay access denied), as if roundcube was external to my server. I haven’t had a chance to look closer at the installation (I’m currently away, with no conneciton to the server).

    Has anyone seen this behavior ?

    Reply
  25. Kevin Allen
    Kevin Allen says:

    Mac Mini running 10.10.1 and Server 4 with the latest topicdesk Roundcube 1.0.3 script install. I can’t seem to get Search results to return anything unless I have “Entire Message” chosen in the search filters drop down menu. Anyone else seeing this issue or is it just me? Any thoughts on where to go to begin to correct things?

    Reply
  26. Kevin Allen
    Kevin Allen says:

    It’s working for us after the update, Wolfgang. I just still can’t get it to properly handle searches that are filtered by sender or from or that sort of thing.

    Reply
  27. Sheldon King
    Sheldon King says:

    Hello. How can we get Roundcube to properly detect identities/alias’s (domains) associated with the account and configure them.

    Reply
  28. Jeff Johnson
    Jeff Johnson says:

    @ Sheldon

    There are different methods to support domains in roundcube

    Two examples:

    1. You could use a plugin that asks the user to provide their details including reply address/domain

    2. Have the user log-in with their complete email address. if the user has never logged in before, this becomes their default reply address.
    Try it with a new user as a test.

    Reply
  29. Jeff Johnson
    Jeff Johnson says:

    If anyone is having trouble with filtering, remember that this is a standard roundcube installation.

    Other filter/vacation plugins are available here:
    Plugin Repo ([url]”http://trac.roundcube.net/wiki/Plugin_Repository”[/url])

    You will find the roundcube installation location and plugin directories here:
    /usr/local/topicdesk/roundcube/WebApp/plugins/
    /usr/local/topicdesk/roundcube/WebApp/

    Jeff

    Reply
  30. Jeff Johnson
    Jeff Johnson says:

    @Philippe ASTIER

    Anyone having trouble with smtp authentication, it could be related to ipv6

    Try this:
    sudo postconf -c /Library/Server/Mail/Config/postfix/ mynetworks

    mynetworks should include “[::1]/128 [fe80::]/10”
    If you don’t see this, you will need to edit /Library/Server/Mail/Config/postfix/main.cf
    find mynetworks and add to it:
    [::1]/128 [fe80::]/10

    then issue
    sudo postfix reload

    If this resolves the issue for anyone, please post for benefit of others.

    Reply
  31. Sheldon King
    Sheldon King says:

    @ Jeff Johnson – yeah that doesnt work because if they sign in with their email address they will only receive their email for that one address correct? Also I dont even think it works to authenticate that way. Yeah just tried doesnt work with email address authentication. Its set to Automatic on the server. In any case. If anyone has any solutions for pulling the correct identities?

    Reply
  32. Jeff Johnson
    Jeff Johnson says:

    @Sheldon

    [quote]”yeah that doesnt work because if they sign in with their email address they will only receive their email for that one address correct? “[/quote]
    Not correct. Roundcube shows any email in the logged in user’s mailbox.
    If 1 user has 5 mail addresses, mail to all of those addresses would be loaded.

    [quote]”Yeah just tried doesnt work with email address authentication.”[/quote]
    I just tested in Mavericks.
    The fullname and shortname were both: jefftest
    In the email addresses box, I entered jeff@domain.com
    I then logged into roundcube entering username: jeff@domain.com
    The user’s idenity in roundcube was setup properly authentication (jeff@domain.com) worked.
    There are some differences with each OS- your mileage may vary.
    You can also add full emails as aliases/shortnames, this has worked since the old days.

    The authentication setting in server.app…. Automatic is never a setting I would use due to issues with DIGEST-MD5.
    Are you able to login to roundcube with an user? Can that user send mail?
    If so, then your auth settings are fine in roundcube.

    Reply
  33. Sheldon King
    Sheldon King says:

    Hi Jeff,

    Yeah cant get any of that to work. I think part of the problem is the username != email@domain.com.

    Ive tried auth method LOGIN and AUTH both neither work. Tried automatic as auth method in the server app and custom settings as well. Cant get any of them to work.

    Also just noticed my carddav isnt working. Can you send me an email? sheldon AT fallswholesale.com

    Thanks.

    Reply
  34. sandor
    sandor says:

    wolfgang –
    i thought the most recent server app update broke roundcube too, but it didn’t – it was merely disabled in advanced settings under the website section of server app.

    Reply
  35. Jason
    Jason says:

    Since 0.9.5 (and we just installed 1.0.3 today) our Filters (sieve) do not work to reply to all messages (out of office). I set the filter up to reply to all messages, fairly simple, they just don’t no out. I’ve checked the postfix logs and there’s no record of it even attempting to send it out. I’ve looked at the filters created by the web GUI in Roundcube and they are syntactically correct. Any one else run into this?

    Reply
  36. Julian
    Julian says:

    I’m having this same ‘Unable to connect to server’ Filters issue with Mavericks Server 3.2.1 & 1.0.3 Roundcube
    The plugin repo page is mentioned but managesieve is included in the install anyway isn’t it?

    Can anybody advise of a step by step fix?

    Reply
  37. Jeff Johnson
    Jeff Johnson says:

    For anyone having issues sending mail from roundcube on yosemite.

    Here’s what I need:

    1. roundcube log of failed smtp
    Enable smtp logging in roundcube
    Add this these lines to the end of: /usr/local/topicdesk/roundcube/WebApp/config/config.inc.php
    [code type=”xml”]$config[‘log_logins’] = true;[/code]
    [code type=”xml”]$config[‘log_session’] = true;[/code]
    Make a few login attempts
    Send the relevant log entries from: /usr/local/topicdesk/roundcube/WebApp/logs/errors

    2. Your postfix config
    [code type=”xml”]sudo postconf -n -c /Library/Server/Mail/Config/postfix/[/code]

    3. Your current roundcube config
    [code type=”xml”]cat /usr/local/topicdesk/roundcube/WebApp/config/{config,defaults}.inc.php[/code]

    Send to jeff at
    topicdesk com

    Reply
  38. Conrad
    Conrad says:

    It’s having SMTP authentication issues like others here. Error was along the lines of: could not add recipient… SMTP authentication failed… Relays not allowed.

    I found that the defaults.inc.php config did not include the %u and %p to authenticate the currently-logged in user for SMTP. I added those and all seems well.

    Hope that helps someone.

    Reply
  39. Jeff Johnson
    Jeff Johnson says:

    SMTP Authentication shouldn’t be required for local delivery.. If it solves the issue, great – but its not necessary.

    Clean installs of 10.10 are working fine
    The issues I’ve seen have all been machines which were upgraded to Yosemite.
    The migrated config is a wildcard – I would have to see your config to provide any recommendations.
    The most common issue a missing IPV6 loopback in main.cf mynetworks

    To check postfix mynetwork setting, run this:
    [code type=”xml”]sudo postconf -c /Library/Server/Mail/Config/postfix/ mynetworks[/code]

    A migrated machine might return this
    mynetworks = 127.0.0.0/8
    or might include your LAN subnet
    mynetworks = 127.0.0.0/8, 10.0.0.0/24

    It needs to include this: [::1]/128
    Assuming your mynetworks is this:
    mynetworks = 127.0.0.0/8, 10.0.0.0/24
    To add the ipv6 loopback, you would run:
    [code type=”xml”]sudo postconf -c /Library/Server/Mail/Config/postfix/ -e “mynetworks= = 127.0.0.0/8, [::1]/128, 10.0.0.0/24″[/code]

    Then restart postfix
    [code type=”xml”]sudo postfix reload[/code]

    Reply
  40. Jeff Johnson
    Jeff Johnson says:

    If you are having errors with the filter (managesieve plugin), try turning ‘DIGEST-MD5’ authentication OFF in Server.app/Mail/Authentication

    Those that do have DIGEST-MD5 authentication enabled may be seeing crepeated crashes of the dovecot-auth.
    /Library/Logs/DiagnosticReports/
    Disable it, stop/start mail service – and sieve/filters should work and the dovecot-auth crashing should stop also.

    Jeff

    Reply
  41. David Muszynski
    David Muszynski says:

    The install was a breeze, but I’ve got a config question. I’m running 10.10.2 and Server 4.0.3.
    I’m hosting multiple domains for web and e-mail. When I log into roundcube it automatically assigns one of the domains that would basically never be used. How do we offer a list of domains to sign in under during login?

    I’m hosting technospider.com, floridapets.org, brevardac.net, huntingthehaunting.com, and pearlharbor911attacks.com
    SSL is turned on only for starfleet.technospider.com, so I use that as my webmail portal. When someone signs in they are automatically set up with the e-mail of (user)@pearlharbor911attacks.com

    Any help is appreciated.

    Reply
  42. Jeff Johnson
    Jeff Johnson says:

    @David Muszynski

    We set defaults to assign users to your primary domain (mydomain in postfix config).
    This fits 9 out of 10 installations.

    The easiest option is to have users login with their full email address (not just shortname) – it then sets the domain based on your login.

    You’ll find plenty of config options and even some plugins to improve the setup for your environment.
    I suggest you checkout the roundcube documentation ([url]”http://roundcube.net/support/”[/url]) and the plugin repository ([url]”http://trac.roundcube.net/wiki/Plugin_Repository”[/url])

    Our installation is standard- you just need to know where to find it:
    /usr/local/topicdesk/roundcube/WebApp/

    Jeff

    Reply
  43. Jeff Johnson
    Jeff Johnson says:

    @ Ricardo

    I’m not sure about signatures – check the roundcube documentation ([url]”http://roundcube.net/support/”[/url]) and the plugin repository ([url]”http://trac.roundcube.net/wiki/Plugin_Repository”[/url])

    Reply
  44. David Muszynski
    David Muszynski says:

    @ Jeff –
    “The easiest option is to have users login with their full email address (not just shortname) – it then sets the domain based on your login.”

    I tried this first. It gave me an error ‘Login Failed’ with some users, others it worked for. It’s kind of strange.

    And I did find the roundcube docs, but I guess I’m just not smart enough to parse them as I saw descriptions of what I wanted to achieve, but not sure how to implement it. And I don’t want to experiment and possibly hose my installation. I guess I’ll have to set up a test server and play around.

    [quote]Configuring for Virtual Users

    Virtual users are useful for hosting providers where a single mailserver is providing email for a number of different domains. The goal is that the user logs in to roundcube with their email login/password, and roundcube knows where to lookup their complete email address. Two options are support, SQL lookups or a sendmail style virtuser file.

    Important: Since version 0.4 this requires enabling the appropriate plugins which are virtuser_file and virtuser_query.

    In order to test if virtuser is configured correctly, log in to roundcube with a user that does not exist yet. Compose a message, if you see the From address as user@correct_domain, then it worked. If you see user@localhost, something is wrong. To reset and try again, delete that user from the roundcube users table (all related records will be removed using foreign keys cascading).

    1) virtuser_file

    $rcmail_config[‘virtuser_file’] = ‘/etc/mail/virtuser’;
    This assumes that the file /etc/mail/virtuser contains information about your virtual users in the following format:

    user@domain login1
    user@domain login2
    2) virtuser_query (SQL)

    $rcmail_config[‘virtuser_query’] = “SELECT email_address FROM database.table WHERE login = ‘%u'”;
    If you are using postfix and/or some kind of hosting panel, chances are your email accounts are already stored in a SQL table. If that is the case, you want to lookup the emails with a virtuser_query. Virtuser_query plugin also allows to set all identity fields using the query. The parts of the example query:

    // email_address – the first column returned by the query must be the complete email address
    // database – name of the database where your table is located, the roundcube db user must have read access
    // table – name of the table where your email addresses are stored
    // login – name of the field that contains the username that is used to log in to roundcube (and send/receive email)[/quote]

    That looks promising, but does the first way mean I have to manually update the virtuser file every time I add a user? And how do I manage the roundcube users table?

    The second way would require me to get some major help from a SQL guru since all I know how to do is set up tables via phpmyadmin for use with Drupal.

    Reply
  45. Jeff Johnson
    Jeff Johnson says:

    @ David Muszynski

    Hi David

    You should consider hiring someone to set this up for you.
    Its not difficult – but paying someone for an hour could save you a day (or more) of setup and trial/error.

    We can assist – or you should be able to find plenty of other consultants available to help with roundcube config.
    http://topicdesk.com/consultancy

    Jeff

    Reply
  46. Bertrand POURCEL
    Bertrand POURCEL says:

    Hi,

    I’ve got problem with vacation plugin.
    It doesn’t work even if it’s correctly setup for the user. (with additional mail adress, etc…)
    Filters set are activated, and filter is activated too
    I see nothing in the logfiles to determine where the problem is…

    Thanks
    Bertrand.

    Yosemite Server 4.03 – TopicDesk Roundcube 1.0.3

    Reply
  47. Jeff Johnson
    Jeff Johnson says:

    @ Bertrand POURCEL

    Try turning -OFF- “Digest-MD5” authentication in Server.app/Mail/CustomAuthentication

    The plugin config file has a logging option.
    The config file is here:
    /usr/local/topicdesk/roundcube/WebApp/plugins/managesieve/config.inc.php

    You will find the option to enable sieve logging
    // Enables debugging of conversation with sieve server. Logs it into /sieve
    $rcmail_config[‘managesieve_debug’] = false;

    You will find general logging options in the config.inc.php and defauilts.inc.php files located here:
    /usr/local/topicdesk/roundcube/WebApp/config/

    The log files are here by default
    /usr/local/topicdesk/roundcube/WebApp/logs/

    Reply
  48. Julian
    Julian says:

    Hi Jeff

    Same issue as Bertrand POURCEL on 2 Servers

    Mavericks Server with 1.0.3 RC
    Digest MD5 is switched off
    The Filters work fine other than the vacation (Reply with message) drop down

    errors log
    r-2015 19:01:45 +0100]: IMAP Error: Login failed for j.lopez from 192.168.11.110. Temporary authentication failure. [osxserver.my_domain.co.uk:2015-04-02 19:01:45] in /usr/local/topicdesk/roundcube/1.0.3a/program/lib/Roundcube/rcube_imap.php on line 184 (GET /mail/?_task=mail&_refresh=1&_mbox=Sent+Messages&_page=1&_action=list&_remote=1&_unlock=loading1427997670906&_=1427997626275)
    [02-Apr-2015 19:25:03 +0100]: IMAP Error: Login failed for j.lopez from 192.168.11.110. Temporary authentication failure. [osxserver.my_domain.co.uk:2015-04-02 19:25:03] in /usr/local/topicdesk/roundcube/1.0.3a/program/lib/Roundcube/rcube_imap.php on line 184 (POST /mail/?_task=mail&_action=refresh?_task=&_action=)
    [02-Apr-2015 19:29:03 +0100]: IMAP Error: Login failed for j.lopez from 192.168.11.110. AUTHENTICATE CRAM-MD5: A0001 NO [UNAVAILABLE] Internal error occurred. Refer to server log for more information. in /usr/local/topicdesk/roundcube/1.0.3a/program/lib/Roundcube/rcube_imap.php on line 184 (POST /mail/?_task=mail&_action=refresh?_task=&_action=)

    the config.inc.php file contains
    // IMAP config
    // To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
    $config[‘default_host’] = ‘localhost’;
    $config[‘default_port’] = 143;
    $config[‘imap_auth_type’] = CRAM_MD5;

    // these are set automatically during installation
    $config[‘db_dsnw’] = ‘sqlite:////usr/local/topicdesk/roundcube/db/sqlite.db?mode=0646’;
    $config[‘plugins’] = array(‘managesieve’, ‘carddav’);
    $rcmail_config[‘support_url’] = “http://osxserver.my_domain.co.uk/”;
    $rcmail_config[‘des_key’] = “WV%s2#X4^79]4F?aj`6Ek=]J”;
    $rcmail_config[‘smtp_helo_host’] = “osxserver.my_domain.co.uk”;
    $config[‘smtp_server’] = ‘localhost’;
    $rcmail_config[‘mail_domain’] = “my_domain.co.uk”;

    Reply
  49. Yoni
    Yoni says:

    I just deployed your installer in OS X 10.10 and upgraded it to Roundcube 1.1.1 stable. Your package works pretty well for the most part. I did notice few things that were out of place in the configuration (at least in your latest package which ships with Roundcube 1.0.3).

    1- $rcmailconfig in ./config/config.inc.php needs to be replaced with $config. ($rcmailconfig has been deprecated since 0.9.5)
    2-Default folders were not properly named or configured to be created by default.
    3- ‘Deleted Messages’ and ‘Sent Messages’ can be left there but the default for OS X is ‘Sent’ and ‘Trash’. Both of them should be defined in the default folders.
    4- Set default folders to be created on user first login. It will prevent issues for those who use webmail even before connecting the Mail client application to their account. Note that Apple Mail creates these folders a they are used. So, save the trouble, time and set it accordingly.
    5- logs and temp folder permissions must be adjusted to allow the webserver to write to those folders _www user/group
    6- Make sure to enable mod_digest, mod_rewrite and mod_expires in apache.

    With those minor changes, your package was indeed very well put together for simplicity and we will look at MyRoundcube Project https://myroundcube.com to include this information taking as base your package.

    Last but not least, it would be good to also recommend users to add a sqlite3 management tool. It helps with management, although this is obviously out of the scope of your package.

    Great work guys!

    Reply
  50. Ian Baker
    Ian Baker says:

    Installed the TopicDesk RoundCube installer, then upgraded to RoundCube 1.1. Both before and after the upgrade, we’ve been having issues with the CardDav plugin. Folks are getting error popups when they attempt to add contacts to their server based address books. How can I debug the issue – is there a way to turn on additional diagnostics for a plugin?

    TIA

    Reply
  51. KPrinz
    KPrinz says:

    After the 10.10.3/Server 4.1 Update roundcube is gone from Apache.
    Is there a simpler step (restore some config) to reneable it, instead of just reinstalling?

    Reply
  52. fonny
    fonny says:

    @KPrinz
    [quote]After the 10.10.3/Server 4.1 Update roundcube is gone from Apache.[/quote]
    Had the same problem. This solved it for me.
    Open Server v4.1
    Started Websites
    At the Websites edit (yourmailserver.com (SSL)
    Edit Advanced Settings…
    Enabled topicdesk-Roundcube

    Reply
  53. Dave Pearce
    Dave Pearce says:

    Hey!

    So I stumbled across this download package when setting up Yosemite with Server app 4.1

    Everything installed fine, I can access RoundCube through Safari at locahost. I can also access RoundCube across the internet at domain.tld/mail Great!!!

    The thing is, I’ve set up a subdomain of webmail.domain.tld and I’ve ticked the option to enable Roubdcube as a web app, but for some reason, when I try accessing the subdomain I am shown the default page for a new website rather than RoundCube login.

    Any ideas?

    Reply
  54. Dave Pearce
    Dave Pearce says:

    Hey!

    So I stumbled across this download package when setting up Yosemite with Server app 4.1

    Everything installed fine, I can access RoundCube through Safari at locahost. I can also access RoundCube across the internet at domain.tld/mail Great!!!

    The thing is, I’ve set up a subdomain of webmail.domain.tld and I’ve ticked the option to enable Roubdcube as a web app, but for some reason, when I try accessing the subdomain I am shown the default page for a new website rather than RoundCube login.

    Any ideas?

    Reply
  55. Alessandro
    Alessandro says:

    As Conrad wrote in here, I found that adding the %u and %p to authenticate the currently-logged in user for SMTP defaults.inc.php config did solve all my SMTP issues.

    Reply
  56. julian
    julian says:

    Hi

    Using round cube 1.0.3 and unable to get the Filter action ‘Reply with message’ to work.
    Can anybody help or advise?

    thanks

    Reply
  57. Alfista
    Alfista says:

    Hi, can anybody help me, how can I update the Roundcube installed with Topickdesk to the latest version?
    Thanks.

    Reply
  58. Stefano Paglino
    Stefano Paglino says:

    Hi,
    this work for me.

    Download the latest version of Roundcube, decompress it.
    Proceed only if your roundcube installation already works (don’t use this to fix an installation) and be sure to backup your system.

    Adjust your paths as necessary

    cd ~/Downloads/roundcubemail-1.1.2/bin
    sudo ./installto.sh /usr/local/topicdesk/roundcube/WebApp
    * enter your password if requested
    * hit y to continue
    * hit y to fix local configuration

    Thats it.. You are running the latest version.

    Reply
  59. Scott
    Scott says:

    Hi,
    I have 0.9.5 on ML 10.8.5 server and it has worked great. Just recently some users could not log in, not getting an error, but the screen turns white fails to connect.

    So I thought a new install would be the answer. But someone above said to install only over a working version. Anybody know what I can try to fix mine?

    Thanks!

    Reply
  60. Jeff Johnson
    Jeff Johnson says:

    Scott

    Try disabling the carddav plugin.. Look in the Roundcube Installer FAQs for some info
    or go directly to
    /usr/local/topicdesk/roundcube/WebApp/config/main.inc.php
    ## remove carddav from the plugin line.

    Your version is dependent on Postgres and its a bit fragile.
    If you don’t mind losing user preferences (full name, signature, edit/compose preferences, etc) then I would delete and re-install (the new version uses sqllite instead of postgres)
    Existing filters and vacation messages will be retained (they are not stored in the user database) but other user preferences will be reset.
    If thats OK with you, then do this:
    sudo rm -rf /usr/local/topicdesk/roundcube
    Then run the new installer.

    If you’d like to run the latest version of roundcbe, after running our installer use the directions in our FAQ section to upgrade.

    Jeff

    Reply
  61. Scott
    Scott says:

    Jeff,
    Sounds good. I don’t really have much in the way of user prefs beside the defaults, but I do have lots of filters and I had saved those out from one of the accounts I could get in to.

    So if I remove what I have and install the newer one, should I still remove that carddav line?

    Also, I’m not clear what you mean in your last line about the latest version of roundcube after the installer. Isn’t the installer 1.03a the latest?

    Thanks!

    Reply
  62. Jeff Johnson
    Jeff Johnson says:

    @Scott

    If you don’t have a working carddav service on your server, then you should remove carddav from the plugin line.
    When the carddav plugin is enabled, it checks the user’s carddav account during login.
    Config issues can cause login delay or faulure.

    We don’t update the installer with every roundcube release because its easy to update roundcube on your own.
    1.0.3 was the current version of roundcube when we built this installer, the latest version is 1.1.2.
    Instructions are in our FAQ section.
    Install instructions

    Reply
  63. Scott
    Scott says:

    Hey Jeff,
    So I removed the carddav as you said and it worked.

    But do you recommend installing the 1.0.3 and then upgrading to 1.1.2?

    Thanks,
    Scott

    Reply
  64. David M
    David M says:

    I’ve installed and set up Roundcube on 2 OS X servers now. Everything works great with one exception.
    Not really a fault of the installer but still an issue I hope someone can help me with.
    I’d like to get shared folders set up on the mail server and don’t know how to do it with 10.10.
    When I had 10.5 (I think) I used SirAdmin to create and share folders for cyradmin.

    Can anyone tell me how to set them up and expose them in Roundcube?

    Thanks,
    David

    Reply
  65. David M
    David M says:

    Sorry to post another question right away, but I just tried to upgrade via your instructions and got these errors:

    PHP Warning: require_once(/usr/local/topicdesk/roundcube/1.0.3a/installer/rcube_install.php): failed to open stream: No such file or directory in /usr/local/topicdesk/roundcube/1.0.3a/bin/update.sh on line 25
    PHP Fatal error: require_once(): Failed opening required ‘/usr/local/topicdesk/roundcube/1.0.3a/installer/rcube_install.php’ (include_path=’/usr/local/topicdesk/roundcube/1.0.3a/program/lib:.:’) in /usr/local/topicdesk/roundcube/1.0.3a/bin/update.sh on line 25

    Reply
  66. Jeff Johnson
    Jeff Johnson says:

    David – Post exactly what steps you took.
    Make sure you run install.sh from the NEW version which should remain in your Downloads folder.
    Don’t manually copy any files.
    Your existing version needs to be running for an upgrade to work.

    Reply
  67. Jeff Johnson
    Jeff Johnson says:

    @David

    I don’t have vetted (postable) instructions.
    Generic instructions for dovecot 2.x will work, the files are just in different location:
    /Library/Server/Mail/Config/dovecot/dovecot.d/

    If you want rough notes, email me
    jeff at topic desk. com

    Reply
  68. Kevin Allen
    Kevin Allen says:

    DEFINITELY backup and test before upgrading to Server App 5.0.3 if you are using the topicdesk install of roundcube. There seems ot be a major change in how server deals with it’s default apps (directing them through port 34543 instead of 443 and 34580 instead of 80 so your default site redirection to roundcube keep adding a :34543 after the domain name before the /webmail in the url. Not sure of a clean fix so far. I’ve got a manageable solution in place by configuring a new website in the server app and setting it to port 443 with some changes to the apache .conf files for the sites themselves. Apple again with a MAJOR change that is undocumented to users before the upgrade is widely available. Test test test test and have a solid backup.

    Reply
  69. Athanasios Alexandrides
    Athanasios Alexandrides says:

    We are in the process of testing it with Server 5 on Yosemite and El Capitan. There is no ETA yet, but I’d think in about 2-3 weeks. When ready, we will post it on our site, tweet about it and send out a newsletter.

    Reply
  70. Roland Sambain
    Roland Sambain says:

    I am experiencing some issues on OSX 10.11.1 and Server 5.0.15. Have to add a ‘/’ to the end of the URL to get it to work which has been reported before and also ‘vacation’ filters that have been disabled continue to function until the filter is actually deleted.

    Reply
  71. Will O.
    Will O. says:

    I just ran the install on my Mac Mini Server El Capitan and it works!!! A big thanks to your team for this amazing solution to a much needed webapp.

    Reply
  72. Thomas
    Thomas says:

    Hi there, after updaten to Server 5.0.3 I can’t connect to round cube any more. What to do?
    Need the “out of office” System. Thanks.

    Reply
      • Jeff Johnson
        Jeff Johnson says:

        Thomas
        Please post the results of these two commands

        grep -E '_https.]'  /usr/local/topicdesk/roundcube/WebApp/config/*
        head /usr/local/topicdesk/roundcube/WebApp/.htaccess
        Reply
        • Thomas
          Thomas says:

          Hi Jeff, here are the results:

          command 1:

          /usr/local/topicdesk/roundcube/WebApp/config/defaults.inc.php:$config['force_https'] = false;
          /usr/local/topicdesk/roundcube/WebApp/config/defaults.inc.php:$config['use_https'] = false;

          command 2:

          DirectoryIndex index.php
          
          # AddDefaultCharset	UTF-8
          AddType text/x-component .htc
          
          
          php_flag	display_errors	Off
          php_flag	log_errors	On
          # php_value	error_log	logs/errors
          Reply
          • Jeff Johnson
            Jeff Johnson says:

            @Thomas

            Please send results of:
            grep topic /var/log/apache2/error_log | tail

            I could take a look directly at your server – it might yield some info to help others. Use the Contact tab above if you are able to arrange remove access.

            Jeff

    • Athanasios Alexandrides
      Athanasios Alexandrides says:

      We are in the process of testing it with Server 5 on Yosemite and El Capitan. Should be ready this month.

      Reply
  73. Q
    Q says:

    just installed the current installer on a server with OS X 10.11.2 and server.app version 5.0.15.
    it worked perfectly right out of the box.
    thanks a lot.

    Reply
    • Jeff Johnson
      Jeff Johnson says:

      @Nick

      The following files/directories are includes in the installer:

      Roundcube:

      /usr/local/topicdesk/roundcube/
      /Library/Server/Web/Config/apache2/webapps/com.topidesk.roundcube.webapp.plist

      mcrypt:

      /usr/local/topicdesk/mcrypt/
      usr//lib/php/extensions/no-debug-non-zts-20090626/mcrypt.so
      usr//lib/php/extensions/no-debug-non-zts-20100525/mcrypt.so
      usr//lib/php/extensions/no-debug-non-zts-20100525/xdebug.so
      usr//lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so
      usr//lib/php/extensions/no-debug-non-zts-20121212/opcache.a
      usr//lib/php/extensions/no-debug-non-zts-20121212/opcache.so
      usr//lib/php/extensions/no-debug-non-zts-20121212/xdebug.so
      usr//local/bin/libmcrypt-config
      usr//local/include/mcrypt.h
      usr//local/include/mutils/mcrypt.h
      usr//local/lib/libmcrypt.4.4.8.dylib
      usr//local/lib/libmcrypt.la
      usr//local/man/man3/mcrypt.3
      usr//local/share/aclocal/libmcrypt.m4
      Reply
  74. MrEdd
    MrEdd says:

    would be great, to have the “pop3fetcher” plugin also pre-installed
    (newbie, so not sure if ‘pre-installation is possible)

    Reply
  75. Dave S
    Dave S says:

    I was running Roundcube 103 on my mavericks server fine but after recently upgrading to el capitan I found I had to reinstall roundcube, after which my server address books are gone, only personal address books exist. I also can’t seem to add an server address book. Is this a problem with your install on El Capitan or just my system? Any help would be appreciated

    Reply

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *