Updating PHP on OS X Server 10.4.x

A tutorial on how to properly update PHP on Mac OS X 10.4.x Server. By Athanasios Alexandrides

Download “Updating PHP on OS X Server” (PDF File) Tweet this!

The purpose of this document is to provide instructions on how to update the version of PHP included with OS X 10.4.x Tiger Server. DO NOT USE this document to update PHP on 10.5.x Leopard Server. A seperate tutorial is available.

It will guide you through updating to the latest version of PHP4 without breaking Server Admin functionality. Furthermore you will be shown how to update to the latest version of PHP5, while retaining most of Server Admin’s functionality.

Although the Apple included version of PHP4 is suitable for most users, there are situations where one might need to update. A common reason is to include support for the GD2 libraries.

This document is written for Mac OS X 10.4.x. However, it should apply to 10.3.x as well. Be aware though that no particular testing of this procedure has been done on 10.3.x.

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.