Error when sending mail from Roundcube Webmail

You can login to Roundcube/Webmail but receive an error when sending.

Possible Solution:
Edit the following file

Add the following 2 lines
$config['smtp_user'] = '%u';
$config['smtp_pass'] = '%p';

Changes take effect immediately, no need to logout.

Test sending mail.

Please leave a comment if this worked for you, or if it didn’t and you’d like additional advice.


10 replies
  1. David Blanchard
    David Blanchard says:

    We’re running MacOS Sierra 10.12.1 and Server 5.2 as well, but Roundcube we let me past the login screen (404 error?) this was an upgrade from older OS where it worked fine. Tried re-installing the 1.14 installer but that didn’t fix it. Tried the webappctl start command shown in the other topic, but didn’t help (but does report round cube as running). Do I need to do a manual upgrade to 1.2.3? Or is something else wrong? Thanks in advance.

    • Sean
      Sean says:

      David, I have almost the exact same problem. Did you ever figure it out?

      I have OS X 10.11.6 with Server 5.1.7 and roundcube 1.2.5. Yesterday I upgraded to macOS 10.12.5 and Server 5.3.1 and I now I see the roundcube login page, but after clicking “login” it’s just a blank page. I don’t see any errors in the web server logs.

      • David Blanchard
        David Blanchard says:

        No, I still have the issue. Right now I have to login like normal, and at the blank page in Firefox (or IE will show a 500 server error), I go up to the address bar and remove the “?_task=login” after “/mail/” and it then goes to the inbox as expected. Just damned annoying, ya know? LOL

  2. Eric
    Eric says:

    Worked for me with OSX 10.13.3 and Server 5.2

    But to get this far I needed
    sudo /Applications/ start com.topicdesk.roundcube
    to get and changed the port used for webdav to 443 get the dates correct.

    I only have one persistent problem now I keep getting these every 30 seconds in my imap server log

    Feb 04 21:47:52 imap-login: Info: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown: SSL alert number 46

    I have not anonymised the message it that is just how it is no user and no ip address.

    • Jeff Johnson
      Jeff Johnson says:

      This is a vacation message, bounce or other server-based reply.

      rip=::1, lip=::1
      This is the IPv6 loopback address. equivilient to ipv4

      The TLS handshake message is ‘info’ level.. its not an error or warning.
      If you have a signed cert, you could eliminate the message by adjusting the imap config to use TLS or SSL and match your signed certificate common name.

      An example.. edit this file

      $config[‘default_host’] = ‘localhost’;
      $config[‘default_host’] = ‘tls://’;


  3. Bo Reeze
    Bo Reeze says:

    Thanks for sharing this!
    Had this annoying “smtp error 454 – 4.7.1 Relay access denied” too and your hint worked out perfectly on 10.11.6/5.2!

    A question concerning TLS/SSL: is this customization mandatory when using TLS/SSL? (because it just works with the default settings)

    $config[‘default_host’] = ‘localhost’; -> ‘ssl://’
    $config[‘default_port’] = 143; -> 993

    $config[‘smtp_server’] = ‘localhost’; -> ‘tls://’
    $config[‘smtp_port’] = 25; -> 587 (you may have to add this line)

    is for most of us some sort of a friend on this issue.

    TIA for your kind reply!

  4. Vic
    Vic says:

    Just updated to roundcube 1.3.6 on Server5.5 and os x High Sierra. Receiving mail works fine, but when sending I get this:
    “SMTP Fehler (504): Die Authentisierung ist fehlgeschlagen.”

    Any idea?



Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *